Endomondo Xiaomi problem gps

Po wyłączeniu wyświetlacza GPS gubi sygnał, pojawia się dopiero po wybudzeniu.

Problem ustawienia oszczędzania baterii, należy:
Ustawienia->Bateria i wydajność->Zarządzaj użyciem baterii przez aplikacje->Wybierz aplikacje->Endomondo
->Bez ograniczeń
oraz
->Lokalizacja w tle -> Zezwól

Android – nie zasłaniaj pomarańczowego obszaru na ekranie

Telefon Xiaomi Redmi. Pojawiał się czesto napis ‚Nie zasłaniaj pomarańczowego obszaru na ekranie. Aby odblokować naciśnij głoścność+ oraz prawy dolny’.

Nie pomagała zmiana parametrów w menu. Pomogło – odcięcie nalepki ekranu z górnej części telefonu (na lewo i prawo od głościnka, pozostawiając na wyświetlaczu). Jest tam czujnik zbliżeniowy i naklejka przezroczysta powodowała, że telefon myślał, że jest w kieszeni!

mikrotik jako PIM router do telewizji (multicast)

/interface vlan
add interface=ether1 name=internet vlan-id=13
add interface=ether1 name=stb vlan-id=401
add interface=ether1 name=transmisja vlan-id=3700
/ip address
add address=192.168.x.50/29 interface=transmisja network=192.168.x.48
add address=172.16.5.2/24 interface=internet network=172.16.5.0
add address=10.1.1.1/24 interface=stb network=10.1.1.0
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall nat
add action=src-nat chain=srcnat out-interface=internet src-address=10.1.1.0/24 to-addresses=172.16.5.2
/ip route
add distance=1 gateway=172.16.5.1
add distance=1 dst-address=10.10.1.x/32 gateway=192.168.x.49
add distance=1 dst-address=10.100.y.0/24 gateway=192.168.x.49
add distance=1 dst-address=192.168.176.0/22 gateway=192.168.x.49
/routing pim
set switch-to-spt-interval=30s
/routing pim interface
add interface=stb
add interface=transmisja
/routing pim rp
add address=10.100.110.z

Nie konfiguruję dhcp, gdyż adresy rozdaje linux 10.1.1.2 w vlanie 401.

Dlaczego nie cisco? Docelowo tak będzie. Mikrotik bierze mniej prądu, na razie wystarcza.
Chciałem użyć do tego OLT Huawei MA5683T, ale wydaje się, że nie ma w nim PIM SM.

Przeniesienie klimatyzatora typu split

Aby przenieść klimatyzator typu split w inne miejsce trzeba rozłączyć rurki. Jest w nich czynnik roboczy, który wcześniej należy odpompować. Można to zrobić używając specjalnej butli oraz pompy próżniowej. Można też wykorzystać zbiornik w jednostce zewnętrznej i jej sprężarkę, zgodnie z poniższym opisem.

Procedura:
1. Zakręcić zawór na cienkiej rurze jednostki zewnętrznej
2. Włączyć chłodzenie
3. Gdy ciśnienie na manometrze spadnie do zera, zakręcić zawór grubej rury na jednostce zewnętrznej (proces trwa ok. 15-30 sekund, w zależności od długości przewodów klimatyzacyjnych. Poznać po tym, że klimatyzator przestaje chłodzić)

Po tym można rozłączyć rurki, przenieść klimatyzację w inne miejsce i podłączyć ponownie.

Uruchamianie Linuksa bez monitora

W nowszych systemach (prawdopodobnie tych z systemd) jeśli uruchomimy komputer bez monitora, a później go podłączymy, monitor nic nie wyświetla.

Sprawdzamy do jakiego wyjścia mamy podpięty monitor:

# for p in /sys/class/drm/*/status; do con=${p%/status}; echo -n „${con#*/card?-}: „; cat $p; done
DP-1: disconnected
DP-2: disconnected
HDMI-A-1: connected
HDMI-A-2: disconnected
VGA-1: connected

Problem rozwiązuje dodanie w grub.cfg (gdzieś w linii linux=vmlinux) video=VGA-1:e

Najlepiej w /etc/default/grub dodać tak:
#GRUB_CMDLINE_LINUX_DEFAULT=””
GRUB_CMDLINE_LINUX=”video=VGA-1:e”

# update-grub
Generating grub configuration file …
Znaleziono obraz Linuksa: /boot/vmlinuz-3.16.0-4-amd64
Znaleziono obraz initrd: /boot/initrd.img-3.16.0-4-amd64
Adding boot menu entry for EFI firmware configuration
gotowe

(problem występuje np. na płycie Q1900M z J1900)

Debian apt-get update NO_PUBKEY

Czytanie list pakietów… Gotowe
W: Dla następujących identyfikatorów kluczy brakuje klucza publicznego:
7638D0442B90D010
NO_PUBKEY 6FB2A1C265FFB764
#
# gpg –keyserver pgpkeys.mit.edu –recv-key 6FB2A1C265FFB764

gpg: zapytanie o klucz 65FFB764 w serwerze hkp pgpkeys.mit.edu
gpg: klucz 65FFB764: klucz publiczny ,,Wheezy Stable Release Key ” wczytano do zbioru
gpg: brak absolutnie zaufanych kluczy
gpg: Ogółem przetworzonych kluczy: 1
gpg: dołączono do zbioru: 1 (RSA: 1)

# gpg –keyserver pgpkeys.mit.edu –recv-key 7638D0442B90D010
gpg: zapytanie o klucz 2B90D010 w serwerze hkp pgpkeys.mit.edu
gpg: klucz 2B90D010: klucz publiczny ,,Debian Archive Automatic Signing Key (8/jessie) ” wczytano do zbioru
gpg: brak absolutnie zaufanych kluczy
gpg: Ogółem przetworzonych kluczy: 1
gpg: dołączono do zbioru: 1 (RSA: 1)

# gpg -a –export 7638D0442B90D010 | apt-key add –
OK

Podstawowa konfiguracja OLT Huawei MA5683T (SCUN)

defaultowy IP 10.11.104.2 login: root hasło: admin
(backspace działa po wciśnięciu CTRL-H)

#display board 0
————————————————————————-
SlotID BoardName Status SubType0 SubType1 Online/Offline
————————————————————————-
0 H805GPFD Normal
1
2
3
4
5
6 H802SCUN Active_normal
7 H802SCUN Standby_normal
8 H801GICF Normal
9 H801X2CS Normal
10
11
12
————————————————————————-

Jeśli któraś z kart nie ma statusu Normal, trzeba ją dodać, np.
config
board add board add 0/0 H805GPFD
board confirm 0/0

Aktualną konfigurację pokazuje:
#display current-configuration

Interfejsem do zarządzania (wyłącznie) jest meth, ustawiamy mu IP:
config
interface meth 0
ip address 172.16.20.1 255.255.255.0
save

Dodajemy VLAN:
config
vlan 300
port vlan 300 0/8 0 (300 to numer VLAN, 8 to karta GICF (zgodnie z display board 0), 0 to pierwszy port)
Możemy ustawić IP na VLANie:
interface vlanif301
ip address 10.10.20.2 255.255.255.0

Ustawiamy autofind na każdym porcie, na którym chcemy aby ONTy zostawały znajdowane:
interface gpon 0/0
port 0 ont-auto-find enable
port 1 ont-auto-find enable

Poniższą komendą można wylistować nieskonfigurowane nowe ONTy:
(config-if-gpon-0/0)#display ont autofind 0
Failure: The automatically found ONTs do not exist
(nie należy podpinać bezpośrednio ONT do OLT, bo sygnał będzie za mocny i ONT nie będzie widoczny, po podłączeniu jednego splittera 1×16 działa)

Dodajemy ONTa:
GAMS(config-if-gpon-0/0)#ont add 1 12 sn-auth „4857544306xxxxxx” omci ont-lineprofile-id 0 ont-srvprofile-id 1 desc „HG850aKK”
Number of ONTs that can be added: 1, success: 1
PortID :1, ONTID :12

GAMS(config-if-gpon-0/0)#display ont info 1 12
—————————————————————————–
F/S/P : 0/0/1
ONT-ID : 12
Control flag : active
Run state : online
Config state : normal
Match state : match
DBA type : SR
ONT distance(m) : 1554
ONT battery state : not support
Memory occupation : –
CPU occupation : –
Temperature : –
Authentic type : SN-auth
SN : 4857544306xxxxxx (HWTC-06D7E510)
Management mode : OMCI
Software work mode : normal
Isolation state : normal
ONT IP 0 address/mask : –
Description : HG850a BG112
Last down cause : –
Last up time : 2017-10-02 21:52:18+08:00
Last down time : –
Last dying gasp time : –
ONT online duration : 0 day(s), 0 hour(s), 0 minute(s), 20 second(s)
Type C support : Not support
Interoperability-mode : ITU-T
—————————————————————————–
VoIP configure method : Default
—————————————————————————–
Line profile ID : 0
Line profile name : line-profile_default_0
—————————————————————————–
FEC upstream switch :Disable
OMCC encrypt switch :Off
Qos mode :GEM-CAR
Mapping mode :VLAN
TR069 management :Disable
TR069 IP index :0
—————————————————————————–
Notes: * indicates Discrete TCONT(TCONT Unbound)
—————————————————————————–
DBA Profile-ID:2
DBA Profile-ID:20
—————————————————————————–
Service profile ID : 1
Service profile name : ont-default
—————————————————————————–
Port-type Port-number
—————————————————————————–
POTS 2
ETH 4
VDSL 0
TDM 0
MOCA 0
CATV 0
—————————————————————————–
TDM port type : E1
TDM service type : TDMoGem
MAC learning function switch : Enable
ONT transparent function switch : Disable
Ring check switch : Disable
Ring port auto-shutdown : Enable
Ring detect frequency : 8 (pps)
Ring resume interval : 300 (s)
Multicast forward mode : Unconcern
Multicast forward VLAN : –
Multicast mode : Unconcern
Upstream IGMP packet forward mode : Unconcern
Upstream IGMP packet forward VLAN : –
Upstream IGMP packet priority : –
Native VLAN option : Concern
Upstream PQ color policy : –
Downstream PQ color policy : –
—————————————————————————–
Port-type Port-ID QinQmode PriorityPolicy Inbound Outbound
—————————————————————————–
ETH 1 unconcern unconcern unconcern unconcern
ETH 2 unconcern unconcern unconcern unconcern
ETH 3 unconcern unconcern unconcern unconcern
ETH 4 unconcern unconcern unconcern unconcern
—————————————————————————–
Notes: * indicates the discretely configured traffic profile,
run the display traffic table ip command to query
traffic table configuration.
—————————————————————————–
Port-type Port-ID DownstreamMode MismatchPolicy
—————————————————————————–
ETH 1 operation discard
ETH 2 operation discard
ETH 3 operation discard
ETH 4 operation discard
—————————————————————————–
Port-type Port-ID Dscp-mapping-table-index
—————————————————————————–
ETH 1 0
ETH 2 0
ETH 3 0
ETH 4 0
IPHOST 1 0
—————————————————————————–
Port-type Port-ID IGMP-mode IGMP-VLAN IGMP-PRI Max-MAC-Count
—————————————————————————–
ETH 1 – – – Unlimited
ETH 2 – – – Unlimited
ETH 3 – – – Unlimited
ETH 4 – – – Unlimited
—————————————————————————–
Alarm policy profile ID : 0
Alarm policy profile name : alarm-policy_0
—————————————————————————–

Najprostsza jest konfiguracja ‚simplified’, tzn. bez ręcznego przydzielania gemportów:

service-port 1012 vlan 300 port 0/0/0 ont 12 iphost multi-service user-vlan 300 tag-transform translate
(do VLANu 300 na OLT, dodajemy końcówkę klienta (ONT) u niego też VLAN 300.
Zmiana hasła:
#terminal user password
User Name(<=15 chars):root Old Password(<=15 chars): New Password(length<8,15>):
Failure: The password must contain at least one digit
New Password(length<8,15>):
Confirm Password(length<8,15>):
Information takes effect
Repeat this operation? (y/n)[n]:n

Oznaczenia kabli energetycznych na mapach WMS

eN – pojedynczy kabel niskiego napięcia, położenie ustalone przed zakopaniem (dawniej ENN)
eNA – pojedynczy kabel niskiego napięcia, położenie ustalone wykrywaczem po zakopaniu (niepewne) – (dawniej EANN)
eS – pojedynczy kabel średniego napięcia, położenie ustalone przed zakopaniem
eSa – pojedynczy kabel średniego napięcia, położenie ustalone wykrywaczem po zakopaniu (niepewne)

2eN, 2eNA, itp. oznacza krotność, czyli ile kabli idzie obok siebie (w odległości od siebie mniejszej niż 1.8m (przy mapie w skali 1:1000)

Głębokość przewodów energetycznych:
90cm pod użytkami rolnymi,
80cm dla średniego napięcia poza użytkami rolnymi,
70cm dla niskiego napięcia poza użytkami rolnymi,
50cm dla oświetlenia ulic, znaków, tablic i sygnalizacji.

SSL test

Aby uzyskać Grade A: https://www.ssllabs.com/ssltest/analyze.html

cd /etc/ssl/private
openssl dhparam -out dhparams.pem 2048
chown 600 dhparams.pem

nginx.conf lub sites-available/file:

ssl_ciphers ‚ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:AES:CAMELLIA:DES-CBC3-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!MD5:!PSK:!aECDH:!EDH-DSS-DES-CBC3-SHA:!EDH-RSA-DES-CBC3-SHA:!KRB5-DES-CBC3-SHA’;

ssl_prefer_server_ciphers on;
ssl_dhparam /etc/ssl/private/dhparams.pem;

DGS 1510 enable telnet

Switch(config)#line telnet
Switch(config-line)#password nowehaslo

Switch(config)#username admin password nowehaslo

Switch(config)#enable password nowehaslo

Switch(config)#ip telnet server

dla ssh podobnie:

Switch(config)#ip enable server

ale trzeba wygenerować klucz.